Recently I was working on installing a HP Officejet 4500 All-in-One Printer Series – G510 for a customer of mine. She had purchased the all in one HP printer on my recommendation, as I had believed that HP makes good printers and all in one devices. However, my this particular experience will make my think twice before recommending another all in one HP device to another customer.

Install Problems:

This was a network (Ethernet) enabled all in one model. So I had connected the printer to the Linksys home router and assigned it a static IP, from the DHCP range that I had configured in the router. Next I ran the setup.ext that came with the printer and selected full install. During the install process, I selected the device as an Ethernet connected and the HP installing detected the printer on the network on its own. So all looked good and the installation finished successfully. I did a reboot to the computer after the installation was complete and then did a test print. And it printed fine. However, when I tried to open the HP all in one console for trying out other features, such as Scan and Copy, the software gave an error saying that the installation is incomplete!! And that I should re-install the software to try and fix the problem.

Attempt to Fix:

I looked around for answers on Google and HP support forums, but all I found was other frustrated people trying to install the same all in one device correctly. So I thought may be the drivers are old and Win 7 may be needing the latest drivers. So with my tech. mind, I downloaded the latest, full driver and software package from HP support site. Uninstalled the software in full and deleted the HP directory from Program Files folder. Did a restart and then tried to install everything fresh again, using the latest drivers and software package that I had downloaded from HP. So I followed the same procedure – installed the full drivers and software package. When the install wizard asked me how I was connected to the printer, I selected network and it went out and successfully detected the printer on the network. The installation completed successfully and rebooted the computer once again. To my surprise and frustration, the same problem happened again. The all in one device would print, but if I tried to launch the software to try out other features such as scan and copy, I would get an error saying that the installation did not complete successfully.

Solution:

After trying out few more things and more failed attempts, I decided to connect the device via a USB cable and attempt to do a fresh install again. So once again, I uninstalled the drivers and software, rebooted the machine, deleted the HP directory from the Program Files folder and tried to install the all in one device again using USB cable.  Behold, it worked! So clearly, there is something wrong with the install package that HP has provided. It does not install properly when the printer is connected via Ethernet cable. And the troubling part is, despite lots of people talking about it on their forum, HP is turning a blind eye to the problem.